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Introduction
Thank you for choosing BackupBuddyVFS!
BackupBuddyVFS is the latest in backup technology from the makers of BackupBuddy®,
the award winning and industry standard backup solution for Palm Powered™ handheld
devices. BackupBuddyVFS is designed to work with organizers that support the Virtual File
System (“VFS”), such as the Palm m500 and m505 and the Sony Clié.
With BackupBuddyVFS installed on your organizer, you can effortlessly backup your
organizer’s critical files to the Sony Clié’s Memory Stick or to Secure Digital or MultiMedia
expansion cards for Palm organizers (“expansion cards”). In the event of a loss of data,
you can then use BackupBuddyVFS to restore your organizer’s data from an expansion
card. As a result, you no longer need to wait until you have access to your Hotsync cradle
or a modem to backup or restore your data.
BackupBuddyVFS provides you with peace of mind when you are on the road - effortless
mobile backups and restores from the company you trust!
Note regarding BackupBuddyVFS:Lite

BackupBuddyVFS:Lite is the limited version of BackupBuddyVFS.
BackupBuddyVFS:Lite enables you to back up all or your organizer’s files to and
restore all of your backup data from your organizer’s expansion card. With the Lite
version, you are not able to perform incremental backups or select individual files for
back up or restore, schedule automatic back ups or perform the other advanced
features described in this manual.

Thanks again for using BackupBuddyVFS.

The Blue Nomad Team
 Blue Nomad, LLC
P.O. Box 287
1017 El Camino Real
Redwood City, CA 94063
www.bluenomad.com

support@bluenomad.com
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Chapter

Features and Requirements
Overview of Features
The following is a general overview of the features of BackupBuddyVFS:
•

OS 5 support including Tungsten T3 collapsing graffiti and landscape view

•

New icon and application graphics added for version 2.1

•

Encryption. You can encrypt all of your data files and backup on your expansion card

•

Ability to backup to and restore files from an expansion card at any time

•

Ability to easily customize what is backed up (or restored)

•

Ability to backup your organizer every time you power off your organizer

•

Incremental backup only backs up files that have been changed since last backup

•

Ability to set a time every day when BackupBuddyVFS will backup your organizer

•

Ability to view your backup log or export a backup log to a memo

•

Restoring an organizer in the event of catastrophic data loss is as simple as launching
BackupBuddyVFS on your expansion card and tapping the Restore button

•

Easy to install: download and install like you would any other Palm application, tap the
Backup icon and rest assured that the organizer's data is secure

•

Optionally backs up files deleted from the organizer to the expansion card so that such files
can be easily located and reinstalled if needed

•

Ability to beam or delete files on your organizer from within BackupBuddyVFS
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•

Jog dial support!

•

Streamlined interface displays the status of backups and restores while they are in progress

Requirements
BackupBuddyVFS requires: Palm OS device with a memory card or Sony handheld device
with Memory Stick. Partial list of supported devices includes:

Palm i705, Palm III Series,
Palm m100 Series, Palm m500, Palm m505, Palm m515,
Palm Tungsten C, Palm Tungsten E, Palm Tungsten T,
Palm Tungsten T2, Palm Tungsten T3, Palm Tungsten W,
Palm V Series, Palm VII Series, Palm Zire Series,
Garmin iQue 3600, Handspring Treo, Handspring Treo 600,
Kyocera 7135, Kyocera QCP 6035, Sony Clie,
Sony CLIE N Series, Sony CLIE NR Series, Sony CLIE NX Series,
Sony CLIE NZ Series, Sony CLIE S Series, Sony CLIE SJ Series,
Sony CLIE SL Series, Sony CLIE T Series, Sony CLIE TG Series,
Sony CLIE UX50 Series…

Other devices with VFS support may be able to use BackupBuddyVFS. Please check with
support@bluenomad.com if you have questions about your specific device.

2

2

Chapter

Getting Started
This Chapter covers installation and the basics to get you started
quickly!

Installing BackupBuddyVFS
To install BackupBuddyVFS, follow these 3 simple steps:
Step 1: Download. Download BackupBuddyVFS and save it to your
computer.
Step 2: Install to Organizer. Use the Palm desktop install tool (or
InstallBuddy) to install BackupBuddyVFS to your organizer, like you would
any other Palm application. Once installed on your organizer, you will see the
Backup application icon shown in the top right of the screenshot below.

Step 3: Install to Expansion Card. Simply launch the Backup program and
you will be prompted to install BackupBuddyVFS onto the expansion card.
You can choose not to install BackupBuddyVFS onto the expansion card, but
we recommend you allow BackupBuddy to make a copy and install it to the
card.
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It is highly recommended that you install BackupBuddyVFS onto your
expansion card. In the event BackupBuddyVFS is deleted from your
organizer (as a result of battery loss or a hard reset, a copy of
BackupBuddyVFS on your expansion card can facilitate the restoration of the
backup data on such card. Please see below for more information on
restoring.
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Note regarding upgrading from the Lite or trial version

If you are upgrading from the Lite or trial version of BackupBuddyVFS,
you can simply install the full version over the Lite or trial version. When
you launch the full version on your organizer, you will be prompted to
install the full version onto your expansion card. There is no need to
remove the other version beforehand.

BackupBuddyVFS Basics
Once installed, BackupBuddyVFS is a breeze to use. This section describes the
basic back up and restore functions that are available in the regular and Lite
version of BackupBuddyVFS. The advanced features are covered in Chapter 3.
BackupBuddyVFS Basic Screen

When you launch the application you will see the basic BackupBuddyVFS
screen shown below. Please note that the basic screen for
BackupBuddyVFS:Lite does not have a Preferences… button.

The basic screen provides you with the following basic options:
Backup. Tapping on the Backup icon will initiate a backup of all of the files
on your organizer to your expansion card and will launch a progress meter
such as the one below. The progress meter tells you where in the back up
process you are.
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With BackupBuddyVFS, only files that have been modified since your last back
up will be backed up. Please note that users of BackupBuddyVFS:Lite do not
have the ability to do incremental backups. In addition, BackupBuddyVFS
users have the option of customizing backups by selecting which files to
back up. Please see Chapter 3 for a description of the advanced features of
BackupBuddyVFS.
Restore. Tapping on the Restore button will initiate restoration of all of the
backup files on your expansion card to your organizer.

Once you have tapped on the Restore button, a Restore progress meter such as
the one above will appear. The progress meter tells you where in the
restoration process you are.
If your organizer has suffered catastrophic data loss and you have installed
BackupBuddyVFS on your organizer’s expansion card, you may recover all
your backup data from the expansion card by doing the following:
•

Launch BackupBuddyVFS on your expansion card. To launch
BackupBuddyVFS on your expansion card, simply launch it like you would any
other application stored on the expansion card. (For example, on Palm devices,
turn on your organizer, use the pull down menu in the upper right hand corner
of your organizer to display all applications on your expansion card, and then
launch BackupBuddyVFS from the expansion card).
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•

Tap the Restore button.
Please note that users of BackupBuddyVFS have the option of customizing
restorations by selecting which backup files to restore. Please see Chapter 3
for a description of the advanced features of BackupBuddyVFS. After your
restore, soft reset the device before use.
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Preferences. Tapping on this button will open the following basic
preferences dialog box. Alternatively, from the basic BackupBuddyVFS screen,
tap on the Menu icon and Options -> Preferences… to open this dialog box.

The basic Preferences dialog box for BackupBuddyVFS has the
following Backup features:
Schedule: You can automatically schedule the time your organizer is backed
up. (note: This option only works from bbvfs on your device. The copy on the
card cannot access the system clock)
Every day at: If you enable this option, your files will automatically be
backed up at a certain time every day.
When I turn my organizer off. If this option is enabled, your files will
be backed up when you turn your organizer off. Please note that
enabling this option will not initiate a backup when your organizer goes
to sleep.
Security: You can now encrypt your backup files with a password of your
choice. Currently only data files (not applications) are encrypted. Simply check
the box for Encrypt my backup files and you will be prompted to enter a
password and then verify the password. Please note that the passwords are
case-sensitive and can only be 7 characters long! Lastly, BackupBuddyVFS uses
the following: encryption algorithm XTEA 32 rounds ECB mode at 56 bits.

Important note: if you forget your password, you will not be able to
recover your backup files.
Password. Click on this button to change your password. Please note that the
passwords are case-sensitive and can only be 7 characters long!
Basic Screen Menus

From the Basic screen you may also access the Options menu shown below.
Please note that BackupBuddyVFS:Lite does not support the Preferences or
Advanced features.
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Delete backup files. Use this feature to delete backup files placed on the
expansion card by BackupBuddyVFS.
View Log… Select to view a log of your most recent backup to the card.
Below is an example of what the log might look like:

Upgrade/Register. Select this option for information on registering
BackupBuddyVFS. Please note that this menu item is only available in the Lite
or trial version, respectively.
Advanced. Select Advanced to access advanced features, such as the ability to
customize your backups and restores by selecting files to backup or restore.
Please see Chapter 3 for a description of the advanced features of
BackupBuddyVFS.
About BackupBuddyVFS. Select this option to see what version of
BackupBuddyVFS you are running.
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Chapter

Advanced Features
This Chapter covers advanced backups, advanced restores and the other
advanced features available with BackupBuddyVFS. To access the advanced
screen shown below and these features, simply launch BackupBuddyVFS on
your organizer, open the Options menu and select Advanced. Subsequent
launches of BackupBuddyVFS will take you directly to the advanced screen. If
you want to view the basic screen, open the Options menu and select Basic.

Advanced Backups.
BackupBuddyVFS lets you select which files you want to back up. To view
the advanced backup screen shown above, launch BackupBuddyVFS and from
the basic screen simply open the Options menu and select Advanced. The
advanced backup screen will list all files that are on your organizer.
Once you have chosen which files to back up, a simple tap of the Backup
button (from the advanced screen) or tap of the Backup icon (from the basic
screen) will back up those files. In the example screenshot above, all files on
the screen except the Verdana FineType font are selected. The advanced
backup features are described below.
Selecting Files for Back Up.

BackupBuddyVFS will back up all files that have been selected for back up.
You can select files for back up by manually checking off the files (i.e., by
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selecting the file name) or by using the File menu -> Select All feature. In the
event you find that you have selected too many files or want to wipe the slate
clean, simply use the Select None option from the File menu. Alternatively, to
unselect any file, simply tap on it again.
Please note that BackupBuddyVFS will only backup files that have been
modified since your last back up. Your first backup may be a bit slow, but
afterwards each backup will be much faster updating only files that have
changed.
Backup.

Once you have decided which files to back up, simply tap on the Backup
button in the lower left hand corner of your organizer’s screen. This will
launch a progress meter such as the one below.

Size of File and Number of Files to be Backed Up.

BackupBuddyVFS lists the size of each file and the number of files to be
backed up. To the right of each file name is the file’s size. In addition, the
number in the lower right hand corner of the screen indicates the number of
files selected to be backed up. OS 5 devices have some system files that
BackupBuddyVFS ignores. So you may be able to select those files, but you
won’t see them in the backup directory. This includes PACE files or files with
“a68k” in the filename. These files don’t need to be backed up and shouldn’t
be restored.

Advanced Restores
BackupBuddyVFS’s advanced restore function is virtually identical to the
advanced backup function. To view the advanced restore screen shown
below, launch BackupBuddyVFS and from the basic screen simply open the
Options menu, select Advanced and then use the pull down menu in the upper
right hand corner to switch the advanced screen to Restore mode. If you are
already in the advanced screen, use the pull down menu in the upper right
hand corner to toggle between the advanced backup and advanced restore
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screen. The advanced restore screen will list all backup files that are in the
backup directory on your organizer’s expansion card.
You may restore one or more or all of your backed up files to your organizer.
This section covers how to restore data in the event of total data loss and how
to restore individual files.
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Selecting Files for Restoration.

BackupBuddyVFS will restore all files that have been selected for restoration.
You can select files for restoration by manually selecting the files (i.e., by
selecting the file name) or by using the File menu -> Select All feature. In the
event you find that you have selected too many files or want to wipe the slate
clean, simply use the Select None option from the File menu. Alternatively, to
unselect any file, simply tap on it again.
Size of File and Number of Files to be Restored.

BackupBuddyVFS lists the size of each file and the number of files selected to
be restored. To the right of each file name is the file’s size. In addition, the
number in the lower right hand corner of the screen indicates the size of all
files to be restored.
Restoring Data in the Event of Total Data Loss.

If your organizer has suffered catastrophic data loss and you have installed
BackupBuddyVFS on your organizer’s expansion card, you may recover data
that you have selected for restoration from the card by doing the following:
•

Launch BackupBuddyVFS on your expansion card. To launch
BackupBuddyVFS on your expansion card, simply launch it like you would any
other application stored on the expansion card. (For example, on Palm devices,
turn on your organizer, use the pull down menu in the upper right hand corner
of your organizer to display all applications on your expansion card category,
then launch BackupBuddyVFS from the expansion card).

•

Tap the Restore icon. You may be in basic mode if you have never launched
the card copy before. You can go to advanced mode or do a basic restore. The
copy on the card may say “Last Backup: Never”. Don’t let this scare you as the
last backup was performed by the copy on the device, not the card copy. Soft
reset the device after restoring data.

Restoring Individual Files.

To restore an individual file or files from your expansion card to your
organizer, simply do the following:
•

Launch BackupBuddyVFS on your organizer

•

Open the Options menu and select Advanced

•

Use the pull down menu in the upper right hand corner and select Restore

•

Select the file(s) you wish to restore

•

Tap on the Restore button
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In the example above, we have selected to restore the WordSmith application.
Once you have selected the file(s) that you want to restore and have tapped on
the Restore button, a Restore progress meter such as the one above will appear.

Advanced Screen Menus
This section describes the features that are accessible from the File and Options
menus of the advanced BackupBuddyVFS screen.
Advanced Screen File Menu

Select All. This menu option lets you select all files for backup or restore.
Select None. This menu option lets you deselect all files for backup or restore.
Delete… This menu option lets you delete any selected file. If you are in the
advanced backup screen, the file will be deleted from your organizer. If you
are in the advanced restore screen and select this option, the file will be
deleted from your backup directory on the expansion card.
Beam. This menu option lets you beam selected files. If you are in the
advanced backup screen, the file will be beamed from your organizer. If you
are in the advanced restore screen and select this option, the file will be
beamed from your expansion card. Please note that this feature will not work
on beam locked files.
Backup All. This menu item provides a shortcut to backup all. You can select
this option and still maintain your backup set.
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Restore All. This menu item provides a shortcut to restore all. You can select
this option and still maintain your restore set.
Remove Orphans. This menu option lets you delete backup copies of files
that have been deleted on your organizer (“orphaned files”).
Advanced Screen Options Menu

View Log… Select to view a log of your most recent backup to the card. When
you choose to view the log, you have the options to Copy or Export. Copy will
copy your log to the Palm Clipboard. You can then paste it into another
application. Export will export a copy of the log to your Memo Pad as seen in
the image on the right below...

Preferences… Selecting this menu option will open the following advanced
preferences dialog box.

The advanced Preferences dialog box for BackupBuddyVFS has the
following options:
Keep orphaned files. If you select to keep orphaned files, any file you delete
from your handheld’s RAM will stay in the backup directory. Normally deleted
files from the handheld (orphans) will be removed from the backup directory
during the next backup.
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Every day at: If you enable this option, the files you have selected for backup
will be automatically backed up at a certain time every day. If you device is off,
BackupBuddyVFS will turn on and perform the backup. Please note: security or
device locks may need to be disabled for this option. If you device is password
locked for example, BBVFS may power on the device, but won’t be able to run
the backup.
Use my backup set. This option will cause BackupBuddyVFS to only
backup the files you have selected in the advanced screen.
At power off. If this option is enabled, the files that you have selected for
backup will be backed up when you turn your organizer off. Please note that
enabling this option will not initiate a backup when your organizer goes to
sleep.
Use my backup set. This option will cause BackupBuddyVFS to only
backup the files you have selected in the advanced screen.
Security: You can now encrypt your backup files with a password of your
choice. Currently only data files (not applications) are encrypted. Simply check
the box for Encrypt my backup files and you will be prompted to enter a
password and then verify the password. Please note that the passwords are
case-sensitive and can only be 7 characters long! Lastly, BackupBuddyVFS uses
the following: encryption algorithm XTEA 32 rounds ECB mode at 56 bits.

Important note: if you forget your password, you will not be able to
recover your backup files.
Password. Click on this button to change your password. Please note that the
passwords are case-sensitive and can only be 7 characters long!
Basic. Selecting this menu option will enable you to get back to the basic
BackupBuddyVFS screen.
About BackupBuddyVFS. Select this option to see what version of
BackupBuddyVFS you are running.

BackupBuddyVFS Limitations
The BackupBuddyVFS currently has the following limitations:
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•

It cannot backup or restore data in flash memory, on HandSpring Visor
Springboard modules or files marked “read-only” on the organizer.

•

GPRS Network preferences may not be restored. These files are in use by
the Palm OS at all times with exclusive read/write access. We recommend
saving your Network logon info in a memo and in the event you need to
restore, you can copy into your Network preferences.

•

Scheduled and Power-off backups can only be performed from RAM.

Removing BackupBuddyVFS
You can remove the BackupBuddyVFS application from your organizer and your
expansion card like you would any other application. The below describes how
to remove the program from a Palm organizer. If you are using a Sony Clie,
please consult the documentation that came with your device.
Recommendation: Delete Backup Files Prior to Removing
BackupBuddyVFS

Before you remove BackupBuddyVFS (or BackupBuddyVFS:Lite), from
your organizer, we recommend that you delete any backup files placed on
your expansion card by our program. These files can be deleted by
BackupBuddyVFS. To delete these files, simply launch BackupBuddyVFS,
open the Options menu and select Delete backup files.
To remove BackupBuddyVFS from your Palm organizer:
Step 1: Tap on the Applications icon and then tap on the Menu icon
Step 2: Select the App menu and then tap on Delete…
Step 3: Select the Backup program and tap the Delete… button.

To remove from the expansion card:
Step 1: Follow steps 1 and 2 above
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Step 2: Use the Delete From: pull down menu to switch the “Delete From:
Handheld” to “Delete From: Card.”
Step 3: Select the Backup program and tap the Delete… button.
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Chapter

Registration and Technical
Support
Registration
If you're using the trial version of BackupBuddyVFS and would like to register
(i.e., purchase) a licensed copy, please visit the purchase center at Blue
Nomad’s website: http://www.bluenomad.com, or write to
sales@bluenomad.com for ordering information.
If you purchase online from our secure web-server, you will immediately be
able to download a registered copy of the software. For instructions on
installing the full version, please see Chapter 2 of this manual.
Please note that Blue Nomad’s license policy is that one license entitles a user to
backup one organizer.
Site Licenses and Special Discounts

In addition, volume discounts and site licenses are available. Please contact our
sales department (sales@bluenomad.com) for details.
Updates & Email Address Changes

If you are a registered user and your email address changes, please let us know
so that we can continue to email you updates and any bug fixes to our
software. When sending us an email address change notification, please
include your full name, old email address and new email address to expedite.
Or, if you think that you may have missed an update, please let us know by
sending us your full name and email address. Please send all such requests to
upgrades@bluenomad.com.
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Technical Support
If you have a question that's not answered in this document, please visit the
support center at www.bluenomad.com to review our frequently asked
questions (FAQs) section. We will constantly be updating our FAQs and our
website to better serve you.
If you don’t find your question in the FAQs, please email your technical
support question to: support@bluenomad.com. We make every effort to answer
email inquiries within one business day (Pacific Standard time).
Spam Arrest, Spam Blocker, Choice Mail users and users of other anti-spam
services, please note: We will not follow any links to be added to your safe list.
If you want to receive a reply to your email, you must add us to your safe list
yourself.
What to include with your support inquiry?

Please include the following with your question:
1. Information on your organizer. Please provide us with information on what
organizer, Palm OS version and type of expansion card you are using. Include
amount of free memory in RAM and on your card. Also if you have any hacks
enabled, try disabling the hacks and please let us know what hacks you have
on the device.
2. Please provide a detailed description of the problem. For example, if you
are experiencing an error, please give us the exact error and the scenario when
the error occurred.
3. Make sure you have the latest version. Please check our website to see that
you have the latest version available.
Thanks for your support!
BackupBuddy is a registered trademark of Alexis Hinds, M.D. BackupBuddyVFS, BackupBuddyVFS:Lite and
InstallBuddy are trademarks of Blue Nomad, LLC.
Palm Computing is a registered trademark of Palm, Inc. or its subsidiaries. Handspring, Visor, and
Springboard are trademarks of Handspring, Inc. All other companies and products listed herein are
trademarks or registered trademarks of their respective holders.
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